summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorꦌꦫꦶꦏ꧀ꦦꦿꦧꦮꦑꦩꦭ꧀ <erik@darapsa.co.id>2022-09-25 13:07:49 +0800
committerꦌꦫꦶꦏ꧀ꦦꦿꦧꦮꦑꦩꦭ꧀ <erik@darapsa.co.id>2022-09-25 13:07:49 +0800
commita264c280b95ead5d1a7ae52823381157a1f1d58b (patch)
tree261742cabb96d0185807215a63af1f4c95162062 /configure.ac
parentd7d98333fe9ec332e3761460af9011527290fe5a (diff)
handle_results is used only when strap is enabled
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 734bb99..319aee9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,7 +6,8 @@ LT_INIT
AC_ARG_ENABLE([strap],
[AS_HELP_STRING([--enable-strap],
[enable Strap template parsing with libtidy])],
- [PKG_CHECK_MODULES([TIDY], [tidy])],
+ [PKG_CHECK_MODULES([TIDY], [tidy])
+ AC_DEFINE([ENABLE_STRAP])],
[enable_strap=no])
AM_CONDITIONAL([STRAP], [test "x$enable_strap" = xyes])
AC_CANONICAL_HOST
@@ -34,6 +35,5 @@ AC_FUNC_MALLOC
AC_FUNC_REALLOC
AC_TYPE_SIZE_T
AC_TYPE_SSIZE_T
-AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT