summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorꦌꦫꦶꦏ꧀ꦦꦿꦧꦮꦑꦩꦭ꧀ <erik@darapsa.co.id>2022-09-25 07:05:32 +0800
committerꦌꦫꦶꦏ꧀ꦦꦿꦧꦮꦑꦩꦭ꧀ <erik@darapsa.co.id>2022-09-25 07:05:32 +0800
commitdfc4062d5aa1e4dc7f44fbb1104638ca78fe9e7b (patch)
treed2b0d1992a7976614e180349c530453ccb14d006 /configure.ac
parent87ee715abd58bb5709637c5e16d1f0b87257f2af (diff)
Turn Strap parsing into a feature
rather than external libtidy package option, though it does, require libtidy to parse Strap, but libtidy will only be used for parsing Strap, not for anything else, seen from the library user's perspective.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 6 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 4d895be..734bb99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,14 +3,12 @@ AM_INIT_AUTOMAKE([-Wall -Werror foreign])
AC_PROG_CC
AM_PROG_AR
LT_INIT
-AC_ARG_WITH([tidy],
- [AS_HELP_STRING([--with-tidy],
- [enable HTML parsing with libtidy])],
- [],
- [with_tidy=no])
-AS_IF([test "x$with_tidy" != xno],
- [PKG_CHECK_MODULES([TIDY], [tidy])])
-AM_CONDITIONAL([TIDY], [test "x$with_tidy" = xyes])
+AC_ARG_ENABLE([strap],
+ [AS_HELP_STRING([--enable-strap],
+ [enable Strap template parsing with libtidy])],
+ [PKG_CHECK_MODULES([TIDY], [tidy])],
+ [enable_strap=no])
+AM_CONDITIONAL([STRAP], [test "x$enable_strap" = xyes])
AC_CANONICAL_HOST
case $host_cpu in
*wasm* ) wasm=true;;