summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorꦌꦫꦶꦏ꧀ꦦꦿꦧꦮꦑꦩꦭ꧀ <prabowo@darapsa.org>2022-10-04 17:00:52 +0800
committerꦌꦫꦶꦏ꧀ꦦꦿꦧꦮꦑꦩꦭ꧀ <prabowo@darapsa.org>2022-10-04 17:00:52 +0800
commit99bd7dc2d2a4e1c35b09c148bd3afb433ef32460 (patch)
tree8af378560a0e68f998e5c276e7090eecb00c45ff /configure.ac
Template that compiles
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..9855fdf
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,21 @@
+AC_INIT([midtrans], [0.0], [prabowo@darapsa.org])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+AC_PROG_CC
+AM_PROG_AR
+LT_INIT
+PKG_CHECK_MODULES([JSON], [json-c])
+AC_CANONICAL_HOST
+case $host in
+ *arm*apple-darwin1* ) ios=true;;
+ *) ios=false;;
+esac
+AM_CONDITIONAL([IOS], [test "x$ios" = xtrue])
+case $host_cpu in
+ *wasm* ) wasm=true;;
+ *) wasm=false;;
+esac
+AM_CONDITIONAL([WASM], [test "x$wasm" = xtrue])
+AS_IF([test "x$wasm" != xtrue],
+ [PKG_CHECK_MODULES([CURL], [libcurl])])
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT