summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorꦌꦫꦶꦏ꧀ꦦꦿꦧꦮꦑꦩꦭ꧀ <prabowo@darapsa.org>2022-10-05 16:01:34 +0800
committerꦌꦫꦶꦏ꧀ꦦꦿꦧꦮꦑꦩꦭ꧀ <prabowo@darapsa.org>2022-10-05 16:01:34 +0800
commit9ab0e1ae6dacbf9bc339cd8ec5b953c17113d242 (patch)
tree433cb2d67239f50cc176a2341b577fb9e8149430 /configure.ac
parent62f61ebe8a9dd3ea8c00fc7f8da9ad426dca0d56 (diff)
Reduce autotools warning/suggestions
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cf39de2..4c58cf8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,8 @@
AC_INIT([midtrans], [0.0], [prabowo@darapsa.org])
AM_INIT_AUTOMAKE([-Wall -Werror foreign])
AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_CXX
AM_PROG_AR
LT_INIT
PKG_CHECK_MODULES([DEPS], [libcurl json-c])
@@ -10,5 +12,8 @@ case $host in
*) ios=false;;
esac
AM_CONDITIONAL([IOS], [test "x$ios" = xtrue])
+AC_FUNC_MALLOC
+AC_TYPE_SIZE_T
AC_CONFIG_FILES([Makefile])
+AC_CONFIG_MACRO_DIRS([m4])
AC_OUTPUT