summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 1 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 9855fdf..cf39de2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,19 +3,12 @@ AM_INIT_AUTOMAKE([-Wall -Werror foreign])
AC_PROG_CC
AM_PROG_AR
LT_INIT
-PKG_CHECK_MODULES([JSON], [json-c])
+PKG_CHECK_MODULES([DEPS], [libcurl json-c])
AC_CANONICAL_HOST
case $host in
*arm*apple-darwin1* ) ios=true;;
*) ios=false;;
esac
AM_CONDITIONAL([IOS], [test "x$ios" = xtrue])
-case $host_cpu in
- *wasm* ) wasm=true;;
- *) wasm=false;;
-esac
-AM_CONDITIONAL([WASM], [test "x$wasm" = xtrue])
-AS_IF([test "x$wasm" != xtrue],
- [PKG_CHECK_MODULES([CURL], [libcurl])])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT