summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorꦌꦫꦶꦏ꧀ꦦꦿꦧꦮꦑꦩꦭ꧀ <erik@darapsa.co.id>2022-02-02 09:29:10 +0800
committerꦌꦫꦶꦏ꧀ꦦꦿꦧꦮꦑꦩꦭ꧀ <erik@darapsa.co.id>2022-02-02 09:29:10 +0800
commit12cde42c929b63a1ef1b2ad7f3482336419980b2 (patch)
tree3c7e7185909432068985da6bb739bf34d67fcd58 /Makefile.am
parentebfa1718a36a8a0f3cf4571bc48b1990129af703 (diff)
Asynchronous connection
Important updates: 1. Emscripten port. 2. HTTP request code copied from libicclient & slightly fixed. 3. Cookies, for maintaining authorisation between different async handles.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 43a977c..71876b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,13 +1,10 @@
lib_LTLIBRARIES = librtclient.la
librtclient_la_SOURCES = \
- request.h \
- request.c \
- post.h \
- post.c \
- user.c \
- ticket.c \
- search.c \
- client.c
+ client.c \
+ request.c \
+ user.c \
+ ticket.c \
+ search.c
librtclient_la_CPPFLAGS = -I${prefix}/include
librtclient_la_LDFLAGS = -L${prefix}/lib
if EMSCRIPTEN
@@ -18,6 +15,7 @@ librtclient_la_LDFLAGS += $(CURL_LIBS)
endif
include_HEADERS = rtclient.h
pkginclude_HEADERS = \
+ rtclient/typedefs.h \
rtclient/user.h \
rtclient/ticket.h \
rtclient/search.h