summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5dbf567..028b315 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,15 @@ AC_FUNC_MALLOC
AC_FUNC_REALLOC
AC_TYPE_SIZE_T
AC_TYPE_SSIZE_T
+AC_CANONICAL_HOST
+case $host_os in
+ *emscripten* ) emscripten=true;;
+ *) emscripten=false;;
+esac
+if test "x$emscripten" = "xfalse"; then
+ PKG_CHECK_MODULES([CURL], [libcurl])
+fi
+AM_CONDITIONAL([EMSCRIPTEN], [test x$emscripten = xtrue])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT