summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorꦌ ꦫꦶ ꦏ꧀ꦦꦿ ꦧ ꦮ ꦑ ꦩ ꦭ꧀ <erik@darapsa.co.id>2019-09-25 10:15:43 +0800
committerꦌ ꦫꦶ ꦏ꧀ꦦꦿ ꦧ ꦮ ꦑ ꦩ ꦭ꧀ <erik@darapsa.co.id>2019-09-25 10:15:43 +0800
commita5e37f8fce723ea98d322ea8712ae6a9a16162e1 (patch)
treef08f96fb5321e696fdd85ae5bb0bfbc76bf974e1 /CMakeLists.txt
parentb7aab36bc1c4bb01f5b26ba63b3daa4caadaaac1 (diff)
CMakeLists.txt
Still having a bug of undefined references when an app links to this library, which they say will be fixed in Qt 5.14.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..6172f3f
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.0.0)
+
+project(qicclient VERSION 0.1 LANGUAGES CXX)
+
+set(CMAKE_AUTOMOC ON)
+
+find_package(Qt5Core)
+
+add_library(${PROJECT_NAME} STATIC
+ client.cxx)
+
+target_link_libraries(${PROJECT_NAME} Qt5::Core)
+
+include_directories(libicclient)