summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorꦌ ꦫꦶ ꦏ꧀ꦦꦿ ꦧ ꦮ ꦑ ꦩ ꦭ꧀ <erik@darapsa.co.id>2019-09-25 10:13:43 +0800
committerꦌ ꦫꦶ ꦏ꧀ꦦꦿ ꦧ ꦮ ꦑ ꦩ ꦭ꧀ <erik@darapsa.co.id>2019-09-25 10:13:43 +0800
commite71900c75a2c557148a67f0aa43058a62c1c6719 (patch)
treedabcb83f43bb2d3efa5d480743a69503cba3f38f /CMakeLists.txt
parentc1d0defeb364527218d1187b9be87872282428a8 (diff)
CMakeLists.txt
Still having a bug of undefined references when an app links to this library, which they say will be fixed in Qt 5.14.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..a8b696d
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.0.0)
+
+project(qrtclient VERSION 0.1 LANGUAGES CXX)
+
+set(CMAKE_AUTOMOC ON)
+
+find_package(Qt5Core)
+
+add_library(${PROJECT_NAME} STATIC
+ user.cxx
+ ticket.cxx
+ client.cxx)
+
+target_link_libraries(${PROJECT_NAME} Qt5::Core)
+
+include_directories(librtclient)