summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorꦌꦫꦶꦏ꧀ꦦꦿꦧꦮꦑꦩꦭ꧀ <erik@darapsa.co.id>2022-09-19 10:25:52 +0800
committerꦌꦫꦶꦏ꧀ꦦꦿꦧꦮꦑꦩꦭ꧀ <erik@darapsa.co.id>2022-09-19 10:25:52 +0800
commit217a3c95a55b54573cda808abdeed7d406437a38 (patch)
tree4285054bce77fc5e61446745e31c4ba43bdf6cdd /Makefile.am
parente4fd03675034dbe97239228c660e6971446b9ee4 (diff)
The main function is run first, it calls JS
which will later call WASM back.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 3bc28cb..8bfd9ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
bin_PROGRAMS = index.js
index_js_SOURCES = pages/index.c
-index_js_LDFLAGS = -s EXTRA_EXPORTED_RUNTIME_METHODS=[cwrap] \
- -s EXPORTED_FUNCTIONS=[_index_getproducts] \
+index_js_LDFLAGS = -s EXPORTED_RUNTIME_METHODS=[cwrap] \
+ -s EXPORTED_FUNCTIONS=[_main,_index_getproducts] \
-s FETCH